poj3070Fibonacci【矩阵快速幂】

2023-09-23 16 0

Language: Default
Fibonacci
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11438   Accepted: 8133

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source

Stanford Local 2006


图片来源:
http://www.cnblogs.com/xudong-bupt/archive/2013/03/19/2966954.html

因此斐波那契数列可用矩阵表示

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
const int MOD=10000;
int ans[2][2];
int a[2][2]={1,1,1,0};
void Mulit(int A[2][2],int B[2][2]){int D[2][2]={0};for(int i=0;i<2;++i){for(int k=0;k<2;++k){if(A[i][k]){for(int j=0;j<2;++j){D[i][j]=(D[i][j]+(A[i][k]*B[k][j]))%MOD;}}}}memcpy(A,D,sizeof(A)*4);
}
void Matrix(int A[2][2],int n){ans[0][0]=ans[1][1]=1;ans[0][1]=ans[1][0]=0;while(n){if(n&1)Mulit(ans,A);Mulit(A,A);n>>=1;}
}
int main()
{int n,i,j,k;while(scanf("%d",&n)&&n!=-1){a[0][0]=a[0][1]=a[1][0]=1;a[1][1]=0;Matrix(a,n);printf("%d\n",ans[0][1]);}return 0;
}
代码编程
赞赏

相关文章

从微信企业邮箱登录入口收发邮件,让工作效率提升数倍
攻略:邮件搬家同一个域名操作步骤,设置邮箱搬家功能的方法
如何添加企业邮箱?企业邮箱添加成员流程分享
各企业邮箱对比,企业邮箱的作用有哪些?
常用外贸邮箱的正确选择让你事半功倍
外贸邮件群发邮箱,看看哪个更适合你的公司吧